pip 对于 python 依赖库的安装十分简单方便.

1. pip/pip3 安装

https://bootstrap.pypa.io/get-pip.py
  • 安装 pip/pip3:
sudo python get-pip.py  # pip
sudo python3 get-pip.py  # pip3

/usr/local/bin 中可以同时看到 pip2 和 pip3。

2. pip/pip3 升级

sudo pip install --upgrade pip  # pip
sudo pip3 install --upgrade pip  # pip3

3. pip/pip3 使用

以 Tensorflow, Keras, IPython 为例.

如,python2 版本:

sudo pip install tensorflow-gpu==1.4
sudo pip install keras==2.1.3

python3 版本:

sudo pip3 install tensorflow-gpu
sudo pip3 install keras

IPython:

sudo pip install ipython==5.7.0  # ipython 6.0 版本以上不支持 python2 了. 终端输入 python 即可.
sudo pip3 install ipython  # ipython 在 6.0 以上, 终端输入 ipython3 即可

sudo pip install ipython --upgrade  # ipython升级到最新版本
Last modification:October 9th, 2018 at 09:31 am